В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
milenakag2008
milenakag2008
26.03.2021 05:23 •  Информатика

Дан массив из элементов. Необходимо найти максимальное и минимальное значение элементов массива.

Формат входных данных

С клавиатуры вводится натуральное число (≤100). На следующей строке через пробел вводятся элементов массива. Все числа целые и по модулю не превосходят 100.

Формат выходных данных

В единственной строке выведите максимум и минимум через пробел.

входные данные выходные данные

6
1 2 3 4 4 1
4 1 python

Показать ответ
Ответ:
zharas5
zharas5
11.09.2021 07:08

(см. объяснение)

Объяснение:

В прикрепленных файлах приведено решение на python и pascal.

ответом будет число 16.

Задание выполнено!

Скопировать код:

##

function F(n: integer): integer;

begin

 if(n<=18) then F:= n+3

 else if((n>18) and (n mod 3 = 0)) then F:= (n div 3)*F(n div 3)+n-12

 else if((n>18) and (n mod 3 >0)) then F:= F(n-1)+n*n+5;

end;

var k: integer := 0;

for var i: integer := 1 to 800 do

begin

 var t: integer := 1;

 foreach var c: char in F(i).ToString do

   if(Integer.Parse(c) mod 2 > 0) then

   begin

     t:= 0;

     break;

   end;

 if(t=1) then k:= k+1;

end;

print(k);

def f(n):

   if n <= 18:

       return n + 3

   elif n > 18 and n % 3 == 0:

       return (n // 3) * f(n // 3) + n - 12

   elif n > 18 and n % 3 > 0:

       return f(n - 1) + n * n + 5

k = 0

for p in range(1, 801):

   e = 1

   for s in str(f(p)):

       if int(s) % 2 > 0:

           e = 0

           break

   if e == 1:

       k += 1

print(k)


Решите на пайтон Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующ
Решите на пайтон Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующ
0,0(0 оценок)
Ответ:
mrtopgame
mrtopgame
11.09.2021 07:08

Программа:

def F(n):

   if n <= 18:

       return n + 3

   elif n > 18 and n % 3 == 0:

       return (n // 3) * F(n // 3) + n - 12

   else:

       return F(n - 1) + n * n + 5

k = 0

for i in range(1, 801):

   m = 0  # Обнуляем переменную проверки длины четных цифр в числе

   for j in range(len(str(F(i:  # Пробежимся по длине числа (От 0 до len('число'))

       if int(str(F(i))[j]) % 2 == 0:  # Проверяем каждую цифру числа на чётность

           m += 1  

   if m == len(str(F(i))):  # Если значение переменной совпадает с длиной числа, то..

       k += 1

print(k)

ответ: 16

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота