В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
алекс922
алекс922
19.04.2020 19:37 •  Информатика

Дан массив mas[1..10]: = 1,3,-1,4,0,-4,-4,3,0,-4. укажите, чему будет равно k после выполнения алгоритма. в ответе укажите число. k: = 1; for i: = 9 downto 1 do for j: =1 to i do if mas[j] > mas[j+1] then begin tmp: = mas[j]; mas[j]: = mas[j+1]; mas[j+1]: = tmp; k: = k + 1; end; write('k = ', k); readln

Показать ответ
Ответ:
Anyazz
Anyazz
02.10.2020 09:32
Это разновидность сортировки обменом - худший её вариант с точки зрения скорости и самый простой для написания: сортировка методом пузырька. Ручной подсчет значения k - количества сделанных в процессе сортировки обменов местами элементов массива, достаточно утомителен, поэтому проще добавить необходимые операторы и выполнить программу.
ответ: k=28
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота