Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
postnovat
24.10.2020 17:37 •
Информатика
Дан массив размера n и целые числа k и l (1 < k ≤ l ≤ n). найти сумму всех элементов массива, кроме элементов с номерами от k до l включительно.
Показать ответ
Ответ:
lelyabolsun
06.10.2020 22:39
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin;
var (n,k,l):=ReadInteger3('Введите через пробел n,k,l:');
var a:=ArrRandom(n,-99,99); a.Println;
Writeln('s=',(a?[:k-1]+a?[l:]).Sum)
end.
Пример
Введите через пробел n,k,l: 15 6 11
-95 -70 45 -58 47 -7 40 -70 -91 42 -51 -76 71 -44 -32
s=-212
0,0
(0 оценок)
Популярные вопросы: Информатика
shhfxecbhawc
19.04.2023 01:26
Какой логический элемент обозначается такой схемой?...
zelenukanna2002
07.01.2023 22:45
Чему будет равно значение переменной a после выполнения данного фрагмента кода? a = 3 b = 2 c = a + b b = 1 a = c * b...
зынзын
21.09.2020 22:08
Слово в памяти компьютера выглядит следующим образом: 01010000 01000001 01011001 С таблицы ASCII определи, что это за слово. dog COW PAY buy...
ЯестьПаша
01.02.2020 01:21
с информатикой если сможете то всё 3 задачи ...
Tigrmigr
18.06.2020 04:24
решить информатика 10 класс...
валера200331
07.04.2023 00:45
Информатика: напишите программу дано действительное х. определить: 0,5х, если х -2 f(x) = 1. х”, в остальных случаях...
sdfsdfsddf
15.06.2021 03:56
1. запиши, к чему - передаче, хранению или обработке информации больше всего относятся следующие действие: заучивание правила по языку. 2.запиши пример передачи информации...
Matveu331
19.09.2020 21:30
Дано действительное х. определить:...
Польди
16.02.2023 22:52
Help with 1st 2nd 3d questions,please...
natchiy03
20.08.2022 05:51
Подскажите где здесь ошибка #include using namespace std; int main (){ int x = 5 int a = 5; if (a % x = 0) { cout простое ; } break; else ( a % x ! = 0){ x++; } }...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin;
var (n,k,l):=ReadInteger3('Введите через пробел n,k,l:');
var a:=ArrRandom(n,-99,99); a.Println;
Writeln('s=',(a?[:k-1]+a?[l:]).Sum)
end.
Пример
Введите через пробел n,k,l: 15 6 11
-95 -70 45 -58 47 -7 40 -70 -91 42 -51 -76 71 -44 -32
s=-212