В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Dikaya24
Dikaya24
24.01.2020 21:37 •  Информатика

Дан одномерный массив A[10]. Элементы массива – это вещественные случайные
числа большие -60 и меньшие 100. Написать программу, которая будет находить
количество элементов массива, кратных числу 8 и больших 10.

Показать ответ
Ответ:
RRuslan619
RRuslan619
30.07.2020 13:13

( Решение на Pascal )

Не совсем ясно, каким образом составители задачи планировали найти среди случайных вещественных 10 чисел в диапазоне от -60 до 100 числа, кратные 8.

Но ради Бога:

var A: array [1..10] of real;

var i,s: integer;

begin

s:=0;

randomize();

for i:=1 to 10 do

 begin

 A[i]:=random()*160-60;

 write(A[i]:3:5,' ');

 if (A[i]>10) and (A[i]-trunc(A[i])=0)  

 and (trunc(A[i]) mod 8 =0) then

 s:=s+1;

 end;

writeln();

writeln('Количество элементов массива,',

'кратных числу 8 и больших 10: ',s);

end.


Дан одномерный массив A[10]. Элементы массива – это вещественные случайные числа большие -60 и меньш
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота