В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Besmertnay123
Besmertnay123
28.02.2023 09:39 •  Информатика

Написать программу при операций div и mod. 1. задано двузначное число. найдите среднее арифметическое цифр числа.

Показать ответ
Ответ:
bgdadanilenko20
bgdadanilenko20
05.08.2020 01:49

var  

 a: integer;

 b,c,s: real;

begin

 writeln('Введите число');

 read(a);

 b:=a div 10;

 c:=a mod 10;

 s:=(b+c)/2;

 writeln('Среднее арифметическое: ',s);

end.  

0,0(0 оценок)
Ответ:
arinka200000
arinka200000
05.08.2020 01:49

var a,b,c:integer;

   s:real;

begin

writeln('Введите двузначное число:');

read(a);

b:=a mod 10;

c:=a div 10;

s:=(b+c)/2;

writeln('Среднее арифметическое: ',s);

end.    

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота