В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
elizawetailjin
elizawetailjin
23.04.2021 11:12 •  Информатика

Дан одномерный массив из n целых чисел. составить программу нахождения максимального и минимального элементов.

Показать ответ
Ответ:
Helpmepleas17
Helpmepleas17
10.07.2020 19:29
Var a:array of integer;
  i,n,mn,mx: integer;
begin
  write('размерность массива = ');
  readln(n);
  SetLength(a, n);
  for i := 0 to n-1 do begin
    write('a[',i,']=');
    readln(a[i]);
  end;
  
  mn := a[0]; 
  mx := a[0];
  for i := 1 to n-1 do begin
    if mn > a[i] then mn := a[i];
    if mx < a[i] then mx := a[i];
  end;
  
  writeln('минимальный элемент = ', mn);
  writeln('максимальный элемент = ', mx);
end.
  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота