В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Azimus19
Azimus19
09.12.2022 00:12 •  Информатика

Дан прямоугольный массив целых положительных чисел 10 х 20. опишите на языке или на одном из языков программирования алгоритм поиска строки с наименьшей суммой элементов. вывести на печать номер строки и сумму ее элементов.
предполагается, что такая строка единственна. составить программу в

Показать ответ
Ответ:
тупойчеловек376
тупойчеловек376
23.05.2020 18:20

program xxx;

  var i, j, k, min : integer;

        a:array[1..10, 1..20] of integer;

        b:array[1..10] of integer;

begin

   for i:=1 to 10 do

     for j:=1 to 20 do

        readln(a[i,j]);

   for i:=1 to 10 do

    begin

     b[i]:=0;

     for j:=1 to 20 do

       b[i]:=b[i]+a[i,j];

    end;

   min:=b[1]; k:=1;

   for i:=2 to 10 do

     if b[i]<min then begin max:=b[i]; k:=i end;

   writeln('наименьшая сумма элементов =', min);

   writeln('она находится в строке -', k);

   readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота