В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Mrx7777
Mrx7777
01.01.2020 08:35 •  Информатика

Дана последовательность целых чисел заканчивающихся нулем написать программу которая́ подсчитывает количество чисел в последовательности.

Показать ответ
Ответ:
tuysdik
tuysdik
20.07.2021 14:19
Уже отвечал, но все же такое решение актуальнее: 

var 
ar:array[1..10] of integer;
max,min,i,kmax,kmin:integer;
begin
randomize;

max:=0;
min:=1000;

for i:=1 to 10 do begin  
ar[i]:=random(1000)+1;  
if (ar[i] > max) then 
  begin max:=ar[i]; kmax:=i; end 
    else if (ar[i] < min) then begin min:=ar[i]; kmin:=i; 
end;  
write(ar[i],' ');
end;

writeln();

if (kmax > kmin) then for i:=kmin+1 to kmax-1 do write(i,' ') 
  else if (kmax < kmin) then for i:=kmax+1 to kmin-1 do write(i,' ');
end.

P.S. В решении выше есть далеко ни одна ошибка ;)
0,0(0 оценок)
Ответ:
kateshopina0703
kateshopina0703
06.05.2020 07:48

Натуральные числа - числа, используемые для счёта предметов. Не являются отрицательными, не являются дробными.

1)1*2=2

2)2*2=4

3)4*2=8

4)8*2=16

5)16*2=32

6)32*2=64

 

При сплошном умножении 62 не получится.

Попробем менять числа местами:

С шага 4) 16 > 61, 61*2=122

С шага 5) 32 > 23, 23*2=46, если 46*2 то будет 92. если 46 поменять местами то будет 64, оба варианта опять не подходят.

С шага 6) 64 > 46, если 46*2 то будет 92. если 46 поменять местами то будет 64, оба варианта опять не подходят.

 

ответ: получить из числа 1 число 62 на таком калькуляторе нельзя.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота