В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Хаурма7
Хаурма7
23.06.2020 19:28 •  Информатика

Дана последовательность из n произвольных целых чисел. написать программу, которая определяет, сколько в этой последовательности отрицательных чисел, кратных 7 (использовать все три вида цикла for, while, repeat)

Показать ответ
Ответ:
школьник619
школьник619
11.08.2020 07:19
Program SomeProgram;var a : array[0..3] of Integer = (1,7,-7,-14);    i : integer;    count : integer = 0;begin
    // с возможно вам нужно с обычного for    for i in a do begin        if ((i div 7) < 0 ) then begin            count := count + 1;        end;    end;    writeln('(for) количество подходящих чисел: ', count);        // с количество подходящих чисел: ', count);        // с тут главное правльно поставить условие после until    i := 0;    count := 0;    repeat        if ((a[i] div 7) < 0) then        begin            count := count + 1;        end;        i := i + 1;    until i = length(a);    writeln('(repeat until) количество подходящих чисел: ', count);    end.

Дана последовательность из n произвольных целых чисел. написать программу, которая определяет, сколь
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота