В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу ! вот условие: даны два действительных числа x и y, не равные друг другу. заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. программа должна иметь дружественный интерфейс. на паскале

Показать ответ
Ответ:
Var x,y,t:real;
Begin
write('x = ');readln(x);
write('y = '); readln(y);
if x>y then
Begin
  t:=y;
  y:=(x+y)/2;
  x:=x*t*2;
End
else
Begin
  t:=x;
  x:=(x+y)/2;
  y:=x*t*2;
End;
writeln('X = ',x:0:2);
writeln('Y = ',y:0:2);
readln;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота