В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
эми46
эми46
18.04.2022 13:39 •  Информатика

Дана строка. Подсчитать в ней количество вхождений букв r, k, t. написать программу в с++

Показать ответ
Ответ:
Olesqqqa
Olesqqqa
20.12.2020 14:59

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

   int r = 0, k = 0, t = 0;

   const int N = 50;

   char array[N];

   cin.getline(array, N);

   for (int i = 0; array[i]; i++)

   {

       if (array[i] == 'r')

       {

           r++;

       }

       if (array[i] == 'k')

       {

           k++;

       }

       if (array[i] == 't')

       {

           t++;

       }

   }

   cout << "r =  " << r << endl;

   cout << "k =  " << k << endl;

   cout << "t =  " << t << endl;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота