В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
алина3894
алина3894
07.10.2020 13:13 •  Информатика

Дано натуральное число n,последовательность целых чисел a1,.составить программу ,которая последовательно прибавляя членв последовательности, выводит результат,когда сумма впервые превышает число n. если сумма всех членов последовательности не превышает число n, выведите об этом сообщение

Показать ответ
Ответ:
aaa1616
aaa1616
24.04.2020 03:48
Const
  n = 5;
 
var
  arr: array [1..n] of integer;
  i, N1, sum: integer;

begin
  write('N = ');
  readln(N1);
  for i := 1 to n do
  begin
    write('A[', i, '] = ');
    readln(arr[i]);
  end;
 
  i := 1;
  sum := 0;
  while (sum <= N1) and (i <= n) do
  begin
    sum := sum + arr[i];
    i := i + 1;
  end;
 
  if sum > N1 then
    writeln(sum)
  else
    writeln('Summa not grether then N');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота