Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
lolipop310
24.08.2020 04:30 •
Информатика
Дано натуральное число. заменить все 7 в данном числе цифрами 8 (через mod) через паскаль !
Показать ответ
Ответ:
nikitalazarev4ozvc33
07.10.2020 12:31
Program z1; Var n,d,s,l: integer; Begin write('Введите число = '); readln(n); l:= 1; s:= 0; while n > 0 do begin d:=n mod 10; if (d = 7) then d:=8; d:= d * l; s:= s + d; l:= l * 10; n:= n div 10; end; writeln(s);End.
0,0
(0 оценок)
Популярные вопросы: Информатика
elenshv
02.05.2023 16:29
Решите ребус 1)лампочка 2)ковычки 3)ковычки 4)веер...
raz1508
20.04.2021 10:34
Что можно моделировать? Информатика...
irishkakrasa
21.04.2021 03:14
Как изменить параметры страницы?Как можно вывести на печать проект в программе Scratch?Какими клавишами пользуемся при копировании, вставке документа?Какими клавишами пользуемся...
Sashka1712
09.05.2020 02:23
В таблице приведена стоимость (руб) проезда между соседними железнодорожными станциями. (Начальную точку смотри в столбике, конечную - в строке наверху)...
Povelitel2004
24.04.2022 17:33
Выполните действие в двоичной системе счисления 101101+110001...
violettaratonina
29.06.2021 06:50
Напишите программу которая определяет находится ли введеный год в настоящем или будущем (работа в паскале )...
аьвтчьвь
13.03.2020 17:21
Информатика. уравнение. паскаль...
khubulovaliza
16.08.2021 04:32
Как будет на казахском 7часов пять минут. семь часов 25 минут..семь часов пятдесят минут. семь часов тридцать минут. нужно...
vladyslav2523
16.08.2021 04:32
Составьте уравнения реакции c4h10+4br2-...
NikulinStasFrost
16.08.2021 04:32
(sinx-cosx)^2=1+cosx решить уравнение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота