В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Дано трёхзначное число. напишите программу, которая определяет: а) есть ли среди цифр заданного целого трёхзначного числа одинаковые; пример входных данных: 123; 121; 222 пример выходных данных: нет; да; да б) является ли число "перевёртышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

Показать ответ
Ответ:
polinagupalo200
polinagupalo200
02.07.2020 01:21
Var x,a,b,c:integer;
begin
writeln ('введи трехзначное число');
readln (x);
c:=x mod 10;
b:=x div 10 mod 10;
a:=x div 100 mod 10;
if a=с then writeln ('Число является перевертышем')
else writeln ('число не является перевертышем');
if (a=b) or (a=c) or (b=c) then writeln ('да')
else writeln ('нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота