В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
gulmamedovaxayald
gulmamedovaxayald
21.07.2022 12:50 •  Информатика

Даны 3 числа. Найти среднее число из этих чисел. Выполнить в Python. Прикрепите фотографию .

Показать ответ
Ответ:
Гульдана111
Гульдана111
29.12.2021 15:33
/*
1. Описать класс с именем MARSH, содержащую следующие, поля:
• BEGST — название начального пункта маршрута;
• TERM — название конечного пункта маршрута;
• NUMER — номер маршрута.
2. Написать программу, выполняющую следующие действия:
• ввод с клавиатуры данных в массив TRAFIC, состоящий из 3 элементов типа MARSH;
• вывод на экран информации о маршруте, номер которого введен с клавиатуры;
• если таких маршрутов нет, выдать на дисплей соответствующее сообщение.
*/

#include <iostream>
using namespace std;

class MARSH
{
public:
string BEGST, TERM, NUMER;

MARSH(string b, string t, string n)
: BEGST(b), TERM(t), NUMER(n)
{
}

MARSH() {}

void info() {
cout << "Маршрут №" << NUMER
<< " (" << BEGST << '-'
<< TERM << ')';
}
};

int main()
{
MARSH TRAFFIC[3];
string b, t, n;
for (int i = 0; i < 3; i++) {
cout << "Ввод данных для маршрута " << i << ':' << endl;
cout << "Название начального пункта маршрута: ";
cin >> b;
cout << "Название конечного пункта маршрута: ";
cin >> t;
cout << "Номер маршрута: ";
cin >> n;
cout << endl;
TRAFFIC[i] = MARSH(b, t, n);
}
cout << endl << "Введите номер маршрута: ";
cin >> n;
MARSH m;
for (int i = 0; i < 3; i++) {
m = TRAFFIC[i];
if (m.NUMER == n) {
m.info();
return 0;
}
}
cout << "Нет маршрута с таким номером!" << endl;
return 1;
}
0,0(0 оценок)
Ответ:
Westix
Westix
25.07.2020 06:04
Var
a,b,c,p:real;
Begin
Write('a = ');Read(a);
Write('b = ');Read(b);
Write('c = ');Read(c);
if (a<b+c)and(b<a+c)and(c<a+b) then
Begin
if (a=b)and(a<>c) then Write('Треугольник равнобедренный, ')
else if (a=b)and(b=c) then Write('Треугольник равносторонний, ')
else if (a*a=b*b+c*c)or(b*b=a*a+c*c)or(c*c=b*b+a*a) then Write('Треугольник прямоульный, ')
else Write('Треугольник никакой, ');
p:=(a+b+c)/2;
a:=sqrt(p*(p-a)*(p-b)*(p-c));
Write('его площадь равна ',a);
End
else Write('Треугольник не существует')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота