В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
pva1992
pva1992
26.02.2021 18:59 •  Информатика

Даны действительное число х не равное нулю и число n целое. составить программу и вычислить сумму ряда s​

Показать ответ
Ответ:
оксана731
оксана731
10.10.2020 11:30

var

 i, n: integer;

 x, s, a, xn: real;

 

begin

 read(n, x);

 a := 1;

 s := 1;

 xn := 1;

 for i := 1 to n do

 begin

   a := a * (2 * i - 1) / sqr (2 * i);

   xn := xn * x;

   s := s - a * xn;

 end;

 write(s * Pi / 2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота