Даны два восьмеричных числа. Требуется написать программу, которая вычисляет их сумму. В программе требуется написать функции перевести число в восьмеричную систему и обратно.
Формат входных данных
Два целых числа в восьмеричной системе от 1 до 109.
Формат выходных данных
Число в восьмеричной системе.
var
a:integer;
b,c:integer;
t:integer;
begin
writeln('Введите двухзначное челое число');
readln(a);
if not((a>9)and(a<100)and(a mod 10<> 0))then
writeln('ERROR');
if (a>9)and(a<100)and(a mod 10 <> 0)then
begin
b := a div 10;
c := a mod 10;
t := b-c;
if t<0 then a:=a+abs(t*10)+t
else a:= a-t*10+t;
writeln(a)
end;
end.
Объяснение:
Данная программа написана на Pascal
В программе я также исключил все числа 10,20,30,40,50,60,70,80,90 , так как при смене местами числа будут получаться однозначные(1,2,3,4,5,6,7,8,9)
Исто́рия информацио́нных техноло́гий берёт своё начало задолго до возникновения современной дисциплины информатика, появившейся в XX веке[⇨]. Информационные технологии (ИТ) связаны с изучением методов и средств сбора, обработки и передачи данных с целью получения информации нового качества о состоянии объекта, процесса или явления.
Ввиду возрастания потребностей человечества в обработке всё большего объёма данных, средства получения информации совершенствовались от самых ранних механических изобретений[⇨] до современных компьютеров[⇨]. Также в рамках информационных технологий идёт развитие сопутствующих математических теорий[⇨], которые сейчас формируют современные концепции[⇨][1].
Информационные технологии активизируют и эффективно используют информационные ресурсы общества (научные знания, открытия, изобретения, технологии, передовой опыт), что позволяет получить существенную экономию других видов ресурсов – сырья, энергии, полезных ископаемых, материалов и оборудования, людских ресурсов, социального времени[2]. К настоящему времени ИТ несколько эволюционных этапов[⇨], смена которых определяется главным образом развитием научно-технического прогресса, появлением новых технических средств переработки информации. Основным техническим средством технологии переработки информации является персональный компьютер, который существенно повлиял как на концепцию построения и использования технологических процессов, так и на качество информации, получаемой после обработки[3].