Даны координаты трёх точек плоскости. Составить программу на языке Java, которая бы определяла бы вид треугольника (равносторонний, равнобедренный, разносторонний, прямоугольный, тупоугольный, остроугольный). Для ввода данных, вычислений и вывода данных использовать отдельные функции (методы). Не использовать глобальные переменные, все необходимые данные передавать в эти функции (методы).
int main(){
int a[10];
int summ1 = 0, summ2 = 0;
for(int i = 0; i < 10; i++){
a[i] = rand()%10 - 3;
cout << a[i] << " ";
if(a[i] < 0) summ1 += a[i];
if(a[i] % 2 != 0) summ2 += a[i];
}
cout << "\nСумма отрицательных элементов равна: " << summ1 << endl;
cout << "Сумма нечетных элементов равна: " << summ2 << endl;
}
2)
int main(){
const int n = 5;
int a[n][n];
int summ1 = 0, summ2 = 0;
for(int i = 0; i < n; i++){
for(int j = 0; j < n; j ++){
a[i][j] = rand()%10 + 1;
cout << a[i][j] << " ";
if(i == j) summ1 += a[i][j];
if(n - 1 == i + j) summ2 += a[i][j];
}
cout << endl;
}
cout << "\nСумма элементов главной диагонали равна: " << summ1 << endl;
cout << "Сумма элементов побочной диагонали равна: " << summ2 << endl;
}
процент отходов отношение второго к первому, умноженное на 100
Язык Python
A = float(raw_input("Введите длинну ребра:"))
R = float(raw_input("Введите радиус:"))
print "Отходов %s процентов" % ((3.1415*4/3*R**3)/(A**3)*100)
2) тут все хитрее, пусть маленький радиус r1, а большой r2,
тогда r2-r1=A и r1/r2=B
решив эту систему получаем
r1 = AB/(1-B) и r2=A/(1-B)
площадь кольца S = 3.14.15*(r2**2-r1**2)
Язык Python
A = float(raw_input("Введите ширину кольца:"))
B = float(raw_input("Введите отношение радиусов:"))
r2 = A/(1-B)
r1=r2*B
print "Площадь кольца %s" % (3.1415*(r2**2-r1**2))