В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Cat6661313
Cat6661313
23.03.2021 21:14 •  Информатика

Даны n целых чисел. составить программу, которая выводит в ответ только те из них, которые кратны трём, но при этом оканчиваются только на 9. проверка n = 15 2 3 19 39 45 12 999 8 15 10 69 89 199 9 16 ответ 39 999 69 9

Показать ответ
Ответ:
Кактус1313
Кактус1313
08.10.2020 12:17
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqInteger(ReadInteger('n ='))
      .Where(t->(t mod 3=0) and (Abs(t) mod 10=9)).Println
end.

Пример
n = 15
2 3 19 39 45 12  999 8 15 10 69 89  199 9 16
39 999 69 9
0,0(0 оценок)
Ответ:
supervte20
supervte20
08.10.2020 12:17
PascalABC.NET

var
n,a:Integer;
list: List<integer> := new List<integer>;
begin
Write('n=');
Read(n);
for var i:= 1 to n do
begin
Read(a);
if (a mod 3 = 0) and (a.ToString().EndsWith('9')) then
list.Add(a);
end;
WriteLn(list);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота