Дайте текст программы паскаль кеша канарейкин обдумывал важное стратегическое решение. он планировал переместиться из точки a в точку b, и дождь, который шёл уже несколько часов кряду, его крайне огорчал. не то чтобы кеша не любил иной раз погулять под дождём, но то, что сейчас происходило за окном, можно было охарактеризовать как сильный ливень. так что кеше хотелось как можно меньшее время находиться на улице. кеша может пойти из a в b по одной из двух дорог. при этом одна дорога имеет длину d1 и на ней встречаются небольшие лужи. кеша может двигаться по этой дороге со скоростью v1. вторая дорога имеет длину d2, но на ней есть участок длины p2, который является одной большой лужей. в этой луже лежат кирпичи, по которым всё же можно через неё перебраться. так что кеша может двигаться по второй дороге со скоростью v2, но, когда идет через лужу, то двигается со скоростью w. ваша — определить дорогу, идя по которой, кеша затратит меньшее время. формат входных данных в первой строке содержатся целые числа d1 и v1 (1 ⩽ d1 ⩽ 100, 1 ⩽ v1 ⩽ 100) — длина первой дороги и скорость, с которой может двигаться по ней кеша. во второй строке содержатся целые числа d2, p2, v2, w (1 ⩽ d2 ⩽ 100, 1 ⩽ p2 ⩽ d2, 1 ⩽ w ⩽ v2 ⩽ 100) — длина второй дороги, длина участка с большой лужей, скорость кеши при движении по второй дороге, скорость кеши при движении по луже. формат выходных данных выведите число 1, если кеше следует пойти по первой дороге, и число 2, если кеше следует пойти по второй дороге. если нет разницы, по какой дороге идти, выведите 0кеша канарейкин обдумывал важное стратегическое решение. он планировал переместиться из точки a в точку b, и дождь, который шёл уже несколько часов кряду, его крайне огорчал. не то чтобы кеша не любил иной раз погулять под дождём, но то, что сейчас происходило за окном, можно было охарактеризовать как сильный ливень. так что кеше хотелось как можно меньшее время находиться на улице. кеша может пойти из a в b по одной из двух дорог. при этом одна дорога имеет длину d1 и на ней встречаются небольшие лужи. кеша может двигаться по этой дороге со скоростью v1. вторая дорога имеет длину d2, но на ней есть участок длины p2, который является одной большой лужей. в этой луже лежат кирпичи, по которым всё же можно через неё перебраться. так что кеша может двигаться по второй дороге со скоростью v2, но, когда идет через лужу, то двигается со скоростью w. ваша — определить дорогу, идя по которой, кеша затратит меньшее время. формат входных данных в первой строке содержатся целые числа d1 и v1 (1 ⩽ d1 ⩽ 100, 1 ⩽ v1 ⩽ 100) — длина первой дороги и скорость, с которой может двигаться по ней кеша. во второй строке содержатся целые числа d2, p2, v2, w (1 ⩽ d2 ⩽ 100, 1 ⩽ p2 ⩽ d2, 1 ⩽ w ⩽ v2 ⩽ 100) — длина второй дороги, длина участка с большой лужей, скорость кеши при движении по второй дороге, скорость кеши при движении по луже. формат выходных данных выведите число 1, если кеше следует пойти по первой дороге, и число 2, если кеше следует пойти по второй дороге. если нет разницы, по какой дороге идти, выведите 0
d1, v1: integer;
d2, p2, v2, w: integer;
t1, t2: real;
begin
readln(d1,v1);
readln(d2,p2,v2,w);
t1:= d1 / v1;
t2:= (d2 - p2) / v2 + (p2 / w);
if (t1 < t2) then
write('1')
else if (t2 < t1) then
write('2')
else
write('0');
end.