В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ivan01356
ivan01356
24.06.2020 04:28 •  Информатика

Для заданного двумерного целочисленного массива mas, являющего квадратной матрицей размерностью n x n и содержащего n^2 произвольных положительных, отрицательных и равных нулю чисел, составить программу для вычисления: найти количество минимальных и количество максимальных чисел матрицы. язык программирования с++

Показать ответ
Ответ:
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <array>
#include <iostream>
#include <algorithm>
#include <utility>
using namespace std;

int main()
{
    array<array<int, 3>, 3> arr2d { { { 5, 4, 0 },
                                      {-3, 5, 7 },
                                      { 8, 2,-1 } } };
    pair<int, int> maxmin(INT_MAX, 0);
    for (const auto& i : arr2d)
   {
        int curr_min  = *min_element(i.cbegin(), i.cend());
        int curr_max  = *max_element(i.cbegin(), i.cend());
        maxmin.first  = maxmin.first > curr_min ? curr_min : maxmin.first;
        maxmin.second = maxmin.second < curr_max ? curr_max :
maxmin.second;
    }
    cout << maxmin.first << " " << maxmin.second;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота