В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
angelina1504
angelina1504
09.06.2022 10:18 •  Информатика

Информатика

Напишите программу на ПАСКАЛЕ умножения всех четных в последовательности 10 целых чисел.

Показать ответ
Ответ:
кисикмиксер
кисикмиксер
15.01.2022 17:30

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

using namespace std;

int main()

{

int i, j, sum=0, n, m, p=1;

cout<<"Введите количество строк:"<<endl;

cin >> n;

cout<<"Введите количество столбцов:"<<endl;

cin >> m;

 int k=i, h=j;

int a[n][m];

int max = a[0][0];

cout<<"Исходный массив:"<<endl;

for (i=0; i<n;i++)

 {

   for (j=0;j<m;j++)

     {

         a[i][j]=-10 + rand()%20;

         cout<<a[i][j]<<" ";

     }

   cout<<endl;

 }

for (i = 0; i < n; i++)

{

 {

   for (j = 0; j < m; j++)

     {

      sum += a[i][j];    

     }

       cout<<"Сумма "<<i<<" строки равна: "<<sum<<endl;

       sum = 0;

  }

 }    

for (j = 0; j < m; j++)

{

 for (i = 0; i < n; i++)

   {

     p *= a[i][j];  

   }

      cout<<"Произведение "<<j<<" столбца равно: "<<p<<endl;

      p = 1;    

 }

for(k=0, h=0; k<n && h<m; k++, h++)

{

 if(a[k][h]>max)

   {

     max = a[k][h];

   }

}

 cout<<"Наибольшее число на главной диагонали: "<<max<<endl;

0,0(0 оценок)
Ответ:
programprogram
programprogram
28.09.2020 11:52

Да это самый удобный и наглядный Рисуем дерево вызовов. Понимаем, что если функция вызвалась с числом <=0, то печатается одна звезда, затем на этой ветке рекурсия останавливается. Если же функция вызвалась с параметром > 0, То печатается 2 звезды и возникают новые две ветки рекурсивных вызовов. Прилагаю рисунок, красными точками отмечены звезды, печатающиеся при конкретном вызове функции. ответо будет являться общее количество таких точек. Важно понять, что при наличии идентичных веток можно посчитать результат для такой ветки один раз и использовать его для других таких же.

ответ: 31.

Объяснение:


Надо решить третий вопрос
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота