В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mynames2
mynames2
24.08.2020 07:18 •  Информатика

Информатика , паскаль Задача:
Чтобы быть всегда чистым, человеку нужно х (24≤х≤50) кусков мыла в год. Если мыть только пяти, то мыла понадобится в 12 раз меньше, а только уши - еще на 1 кусок меньше. Составить программу, которая по выбору пользователя давала ответ количество кусков мыла необходимо закупить на n лет вперед, чтобы: мыться полностью; мыть только пятки;мить только уши;мыть пятки и уши

Показать ответ
Ответ:
kokokola20
kokokola20
03.01.2021 19:21

var x1:real:=24;

   x2:real:=50;

    N:real;

begin

write('Введите число лет: '); readln(N);

var A:=((x1/12).Round*N,(x2/12).Round*N);

var B:=(((x1/12).Round-1)*N,((x2/12).Round-1)*N);

writeln('Для мытья полностью нужно ',x1*N,'-',x2*N,' кусков мыла');

writeln('Для мытья одних пяток нужно ',A[0],'-',A[1],' кусков мыла');

writeln('Для мытья одних ушей нужно ',B[0],'-',B[1],' кусков мыла');

writeln('Для мытья пяток и ушей нужно ',A[0]+B[0],'-',A[1]+B[1],' кусков мыла');

end.

Объяснение:

В программе использован метод кортежей (Tuple): A и В - переменные с двумя ячейками под запись. Значения внутри них нельзя изменить, однако можно считать, подобно обращению к массиву. При том следует помнить, что нумерация индексов (адресов ячеек) начинается с нуля. Используя B[0] мы обращаемся к первому его значению, то есть к выражению ((x1/12).Round-1)*N.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота