Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
QueenAlinacom
19.08.2020 11:46 •
Информатика
Информатика. составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 0 до 10 и находит сумму минимального и максимального элементов массива
Показать ответ
Ответ:
oleca3
04.10.2020 18:08
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,0,10); a.Println;
Writeln(a.Max+a.Min)
end.
Пример
6 5 4 7 5 8 8 10 0 2
10
0,0
(0 оценок)
Ответ:
1dianalady1
04.10.2020 18:08
Си.
#include <stdio.h>
#include <stdlib.h>
void main( void )
{
int A[10], max = A[0], min = A[0], i;
for (i = 0; i < 10; i++)
{
A[i] = rand() / RAND_MAX * 10;
if (A[i] < min)
min = A[i];
if (A[i] > max)
max = A[i];
}
}
printf("Sum of min & max: %i", (max + min));
0,0
(0 оценок)
Популярные вопросы: Информатика
Анастасия2787
16.11.2021 18:27
Объявлен набор в школьную баскетбольную команду.известен рост каждого из n учеников желающих попасть в эту команду. составьте алгоритм подсчета количества претендентов...
Нуб0001
12.12.2022 12:20
Построить линейный рекурентный регистр сдвига с обратной связью по функции f(x)=x^5+x^3+x+1...
vNeronRazerv
12.12.2022 12:20
Составить блок-схему и написать программу ввода с клавиатуры числа и проверить отрицательное ли оно или оканчивается на 3....
nastyagrigorov
17.03.2022 17:59
Составьте таблицу сходства и различия между текстом редактором word пап и блокнотом с текстом процессором вас мне решить так как я отличница но у меня много много уроков...
ssnn70p0aegz
14.10.2020 03:08
Как написать имя настя в кумире команды черепашки...
Ксюнька1801
07.03.2022 14:59
Заполните массив случайными числами в интервале {-100,100} и представить элементы так, чтобы все положительные элементы стояли в начале массива, а все отрицательные и...
Nadachansky
25.02.2020 00:40
Программы для pascalabc 1. найти сумму однозначных чисел из n заданных. 2. найти кол-во отрицательных чисел из n заданных. 3. найти произведение нечётных чисел из n заданных....
снежана195
21.09.2022 05:36
Последовательно ввести n чисел, определить сколько среди них было введено четных (с оператором repeat и на abcpascal)...
Quickpool
17.08.2021 12:30
Даны три целых двузначных числа, вывести число в котором вторая цифра (разряд единиц) больше 27, 15, 19...
AlexCh1
07.06.2022 23:21
Где научиться работать в экселе?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,0,10); a.Println;
Writeln(a.Max+a.Min)
end.
Пример
6 5 4 7 5 8 8 10 0 2
10
#include <stdio.h>
#include <stdlib.h>
void main( void )
{
int A[10], max = A[0], min = A[0], i;
for (i = 0; i < 10; i++)
{
A[i] = rand() / RAND_MAX * 10;
if (A[i] < min)
min = A[i];
if (A[i] > max)
max = A[i];
}
}
printf("Sum of min & max: %i", (max + min));