В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Karina1155
Karina1155
28.11.2022 21:49 •  Информатика

Исправить ошибки
Условие задачи: составить программу обмена местами двух чисел c и d (Числа не дробные).
Var c,d m:integer;
Procedure obmen (а, b:string)
var m:integer;
begin
m:=a; a:=b; b:=m
writeln (a,b);
begin
writeln (‘Введите 3 числа:’);
readln (c,d);
begin
obmen (с;d);
writeln (с, ‘ ’, d)
end.

Показать ответ
Ответ:
mvsigatova
mvsigatova
08.03.2023 11:55
ответ: K = 0, L = 0, M = 0, N = 1.

Строишь таблицу истинности. Просто выполняешь каждое действие и заносишь его в таблицу.
⇒ импликация. Таблица истинности во вложении. Если математически, то это условие: a ≤ b. Если оно выполняется, то условие истинно.
Т.е. если a = 1, b = 0, то a ⇒ b = 0(ложь). Во всех остальных случаях 1(истина).

Выполнять надо по приоритету, как в математике. Сначала отрицание ¬, умножение ∧, сложение ∨ и т.д. Импликацию ⇒  обычно делают в конце, если нет эквивалентности ~. Ну и стоит обращать внимание на скобки.
0,0(0 оценок)
Ответ:
znanija140
znanija140
18.04.2020 22:23

В курсе информатики при изучении раздела "Алгоритмы и исполнители" рассматривают исполнителя Чертежник.

Чертежник - это виртуальный компьютерный исполнитель, который предназначен для построения рисунков и чертежей на координатной плоскости, и представляет собой перо, которое  может поднимать, опускать и перемещать.

При перемещении опущенного пера за ним остается след.

Среда обитания - часть координатной плоскости (1-я четверть, где х и у - положительны).

Начальное положение Чертежника - точка (0; 0) и перо поднято.

После исполнения программы перо должно быть поднято и и находится в начале координат - точке (0; 0).

Основные команды:

field(m,n) - создать поле размером m×n

topoint(x,y) - переместить перо в точку (х; у)

penup - поднять перо

pendown - опустить перо

onvector(a,b) - сместить перо на вектор (a; b)

m и n - натуральные числа

х и у - целые числа

Подробнее - на -

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота