В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Lapatkoanna
Lapatkoanna
06.10.2020 21:22 •  Информатика

Изначально, была такая: на вход программы подается натуральное число. требуется написать программу, которая определяет составное или простое число на входе и выводит сумму его цифр. я написал первую часть программы (без вывода суммы цифр) : program sg3; uses crt; var i,a,k: integer; begin clrscr; write('введите число: '); readln(a); k: =0; for i: =2 to a div 2 do if a mod i =0 then k: =k+1; if k=0 then write('простое') else writeln('составное'); readln; end. допишите код, который бы выводил сумму цифр,паскаль

Показать ответ
Ответ:
LeadingLady
LeadingLady
08.07.2020 20:09
Program sg3;
uses crt;
var i,a,k, sum: integer;
begin
clrscr;
write('Введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then
k:=k+1;
if k=0 then
write('Простое')
else
writeln('Составное');
while (a<>0) do
begin
sum:=sum+(a mod 10);
a:=a div 10;
end;
write('Сумма цифр= ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота