В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
tanyamonter
tanyamonter
06.03.2022 10:25 •  Информатика

Лёгкая по паскалю! составьте программу, которая позволяет заменить в строке s слово t1 на слово t2. строку s и слова t1 и t2 введите с клавиатуры. пример ввода: на небе появилась туча. туча луна пример вывода: на небе появилась луна.

Показать ответ
Ответ:
влад20491
влад20491
04.10.2020 15:34
Var
  s, t1, t2, st: string;
  i: integer;
begin
  readln(s);
  readln(t1);
  readln(t2);
  if pos(t1, s) <> 0 then
    i := pos(t1, s);
  st := copy(s, 1, i - 1);
  st := st + t2;
  st := st + copy(s, i + length(t1), length(s));
  writeln(st);
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота