В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
GoldGriffon
GoldGriffon
28.03.2022 22:50 •  Информатика

Массив содержит четное количество элементов. Напишите программу, которая сортирует вторую половину массива – по убыванию. Каждый элемент должен остаться в «своей» половине.

Показать ответ
Ответ:
nadyam1982
nadyam1982
08.05.2022 15:28

program fantscrin;

    var x_1,x_2,h,j,i: integer; f: boolean; a: array [1..3] of string; k,l: string;

    function chek_number(a: integer): boolean;

    var k: integer;

    begin

      if (a mod 2 < > 0) then  

                        begin  

                          chek_number: =false;

                          exit;

                        end;                  

      while a > 0 do

      begin

        a: =a div 10;

        k: =k+1;

      end;

      if (k = 3) then chek_number: =true

                else chek_number: =false;  

    end;

begin

    f: =false;

    while f = false do

    begin

      write('введите 1-ое число: '); readln(x_1);

      f: =chek_number(x_1);

    end;

    f: =false;

    while f = false do

    begin

      write('введите 2-ое число: '); readln(x_2);

      f: =chek_number(x_2);

      if (f) then if (x_1 < > x_2) then f: =true

                                  else f: =false;

    end;

   

    str(x_2,l);

    str(x_1,k);

    i: =1;

    h: =1;

    while i< =3 do

    begin

      j: =1;

      while j< =3 do

      begin

        if (k[i] = l[j]) then  

                        begin    

                            a[h]: =k[i];

                            h: =h+1;

                        end;

        j: =j+1;

      end;

      i: =i+1;

    end;

    writeln('');  

    i: =1;

    while i < =3 do

    begin

      write (a[i], '   ');

      i: =i+1;

    end;

end.

0,0(0 оценок)
Ответ:
zhenyakulakova
zhenyakulakova
31.01.2020 03:24
// тестировалось на C#.Net Framework 4.5
using System;

class Program
{
    static void Main()
    {
        int x1 = 2, y1 = 1;
        int x2 = 6, y2 = 5;
        int x3 = 10, y3 = 1;

        var a = Distance(x2, y2, x3, y3);
        var b = Distance(x1, y1, x3, y3);
        var c = Distance(x2, y2, x1, y1);

       
        Console.WriteLine("S = {0}", Square(a, b, c));
        Console.ReadKey();
    }

    //растояние между точками
    static double Distance(int x1, int y1, int x2, int y2)
    {
        return Math.Sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
    }

    //формула герона
    static double Square(double a, double b, double c)
    {
        var p = (a + b + c) / 2;
        return Math.Sqrt(p * (p - a) * (p - b) * (p - c));
    }

    // теорема косинусов
    static double Angle(double a, double b, double c)
    {
        return Math.Acos((b * b + c * c - a * a) / (2 * b * c));
    }

    static bool IsAcuteAngel(double alpha)
    {
        return alpha < Math.PI / 2;
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота