Массив содержит нечётное количество элементов.отсортировать первую половину массива по убыванию ,вторую по возрастанию.средний элемент заменить на ноль . составить программу на паскале
дешифровки: Const sh = '_.,'; Var St : String; i : Integer; Function DeCode(S : String; Tabl : String; k : Integer) : String; Var j,n : Integer; Begin For j:=1 to Length(S) do Begin n:=Pos(S[j],sh); If n>0 then Begin n:=n+k; While n>Length(sh) do n:=n-Length(sh); While n<=0 do n:=n+Length(sh); S[j]:=sh[n]; end end; DeCode:=S; end; Begin St:='ЗЫФЙГФШРЦ . ШД'; Writeln(Decode(St,sh,-6)); //For i:=-10 to 10 do Writeln(Decode(St,sh,i)); end.
1. Нажать ctrl+H и в строчке "что" написать ) а в строчне "Заменить на" )_ - _это пробел или скобка это ", тогда этот символ 2. Грамматические и Орфографические, Пунктуация. Нажмите кнопку Microsoft Office, а затем выберите элемент Параметры Word. Щелкните пункт Правописание. Нажмите кнопку Параметры автозамены. На вкладке Автозамена установите флажок Автоматически исправлять орфографические ошибки. 4. Чтобы быстро убрать все лишние пробелы и табуляторы в началах и концах строк, выделите весь текст, задайте выравнивание по центру – пробелы будут удалены. После этого задайте нужное выравнивание, например по ширине. Выберите меню Правка | Заменить… В поле «Найти» введите пробел (нажмите на пробел). Нажмите кнопку «Больше», чтобы раскрыть диалог. Нажмите кнопку «Специальный» и появившемся меню выберите Знак абзаца. В поле «Найти» добавится текст «^p». В поле «Заменить на» вставьте один знак абзаца «^p». Нажмите кнопку «Заменить всё»
дешифровки:
Const sh = '_.,';
Var
St : String;
i : Integer;
Function DeCode(S : String; Tabl : String; k : Integer) : String;
Var j,n : Integer;
Begin
For j:=1 to Length(S) do
Begin
n:=Pos(S[j],sh);
If n>0 then
Begin
n:=n+k;
While n>Length(sh) do n:=n-Length(sh);
While n<=0 do n:=n+Length(sh);
S[j]:=sh[n];
end
end;
DeCode:=S;
end;
Begin
St:='ЗЫФЙГФШРЦ . ШД';
Writeln(Decode(St,sh,-6));
//For i:=-10 to 10 do Writeln(Decode(St,sh,i));
end.
а в строчне "Заменить на" )_ - _это пробел
или скобка это ", тогда этот символ
2. Грамматические и Орфографические, Пунктуация. Нажмите кнопку Microsoft Office, а затем выберите элемент Параметры Word.
Щелкните пункт Правописание.
Нажмите кнопку Параметры автозамены.
На вкладке Автозамена установите флажок Автоматически исправлять орфографические ошибки.
4. Чтобы быстро убрать все лишние пробелы и табуляторы в началах и концах строк, выделите весь текст, задайте выравнивание по центру – пробелы будут удалены. После этого задайте нужное выравнивание, например по ширине. Выберите меню Правка | Заменить… В поле «Найти» введите пробел (нажмите на пробел). Нажмите кнопку «Больше», чтобы раскрыть диалог. Нажмите кнопку «Специальный» и появившемся меню выберите Знак абзаца. В поле «Найти» добавится текст «^p». В поле «Заменить на» вставьте один знак абзаца «^p». Нажмите кнопку «Заменить всё»
Как-то так наверное,не уверена