В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Blaxi
Blaxi
26.03.2022 10:11 •  Информатика

Может кто-нибудь с задачей?

"3. Программа получает на вход последовательность из N целых неотрицательных чисел. Найти количество всех цифр в последовательности чисел.

Ввод данных:
N = 5
23 475 12 1 683"

Нужно решить на Питоне и с использованием цикла while. Понятие того, что можно сделать, есть, но в голову не приходит, как это написать. Буду благодарить вас за столько, сколько хотите, но сильно нужна заранее!

Показать ответ
Ответ:
fylkis
fylkis
12.10.2020 06:59

N = int(input())

number_list = str(input()).split()

if len(number_list) != N:

   quit()

letter_list = []

for n in number_list:

   for i in n:

       letter_list.append(i)

amount = 0

for letter in letter_list:

   amount += int(letter)

print(letter_list)

print(amount)

забыл что нужно через while =(

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота