В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Дазуки
Дазуки
12.09.2021 21:59 •  Информатика

На c++ дан массив, состоящий из nn элементов. требуется добавить в него число x на позицию p. при этом все элементы с позиций в диапазоне [p; n]должны сдвинуться на элемент вправо. формат входных данных в первой строке входных данных дается число nn (1≤n≤100). в следующей строке даны n чисел, каждое из которых по модулю не превосходит 10 в 9 степени. на третьей строке число xx (также по модулю не превосходящее 10 в 9 степени) и число p (1≤p≤n+1). все числа во входных данных целые. формат выходных данных требуется вывести обновленную последовательность, хранимую в массиве.

Показать ответ
Ответ:
vseznaika29
vseznaika29
09.09.2020 07:25
#include <iostream>
using namespace std;

int main() {
int n, x, p;
cin >> n;
int a[n+1];
for (int i=0; i<n; i++){
cin >> a[i];
}
cin >> x >> p;
for (int i=n; i>p-1; i--){
a[i] = a[i-1];
}
a[p-1] = x;
for (int i=0; i<n+1; i++){
cout << a[i] << " ";
}
cout << "\n";
return 0;
}

Пример:
5
4 2 9 7 3
8 4
4 2 9 8 7 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота