В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

На c++ требуется написать программу, которая определяет цифры исходного четырёхзначного числа x и выводит их на экран. формат входных данных входной поток содержит целое число x (1000≤x≤9999) формат выходных данных выведите цифры числа xx по одному в строке, в следующем порядке: тысячи, сотни, десятки и затем единицы.

Показать ответ
Ответ:
mement0m0ri
mement0m0ri
26.08.2020 06:05
#include <iostream>
using namespace std;

int main()
{
    int a, b;
    cout << "a = ", cin >> a, cout << "\n";
    b = a/1000;
    cout << b << "\n";
    b = a/100 % 10;
    cout << b << "\n";
    b = a % 100 / 10;
    cout << b << "\n";
    b = a % 10;
    cout << b << "\n";
    return 0;
}

Пример:
a = 7052
7
0
5
2
На c++ требуется написать программу, которая определяет цифры исходного четырёхзначного числа x и вы
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота