В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gopina04vika
gopina04vika
12.10.2021 03:21 •  Информатика

на C#

Задание:
Дана точка на плоскости с координатами (x,y). Составить программу которая выдаёт одно из сообщений "да", "нет", "на границе" в зависимости от того лежит ли точка вгибом заштрихованной области, вне заштрихованной области или на её границе. Области заедаются графически следующим образом


на C# Задание: Дана точка на плоскости с координатами (x,y). Составить программу которая выдаёт одно

Показать ответ
Ответ:
pridanivdanil
pridanivdanil
15.04.2023 02:37
1. Определим скорость передачи в Мб/с

1 байт = 8 = 2³ бит.
1 Мбайт = (2¹⁰)² = 2²⁰ байт = 2²⁰ × 2³ = 2²³ бит.
Скорость 2¹⁸ бит/с равна 2¹⁸ / 2²³ = 2⁻⁶ Мбайт/с

2. Определим время, необходимое для передачи файла по А

10 Мбайт / 2⁻⁶ Мбайт/с = 10 × 32 с = 320 с

3. Определим время, необходимое для передачи файла по Б.

Объем файла после архивации составит 30% от объема исходного, следовательно и время передачи файла также будет составлять 30% от времени по варианту А.
320 с × 0.3 = 96 с
И еще 7 + 1 = 8 с нужны на подготовку файла.
Итого, время по варианту Б составит 96 + 8 = 104 с.

4. По варианту Б время меньше на 320 - 104 = 216 с, т.е. этот вариант быстрее.

ответ: Б216
0,0(0 оценок)
Ответ:
dierchik25
dierchik25
25.04.2020 06:03

1 программа:

var x, y, t:integer;

begin

 for x:=3 to 15 do begin

   writeln('x = ', x);

   t := x - 2;

   y := 7*t*3-6*t+10;

   writeln('y = ', y);

   writeln('');

 end;

end.

2 программа:

const pass ='45xlua';

var x:string;

a:boolean;

begin

 a:= false;

 while a<>true do begin

    writeln('Введите пароль');

    readln(x);

    if x = pass then begin

      a:=true;

      writeln('Пароль верный');

      end

    else

      writeln('Пароль неверный, введите еще раз');

    writeln('');

 end;

end.

4 программа:

var a, a1, a2, x, kol:integer;

begin

writeln('Введите четырёхзначное число');

readln(a);

x := a;

while x<>0 do begin

  x:= x div 10;

  kol:= kol + 1;

  end;

 if (kol = 4) then begin

   a1 := a div 100;

   a2:= a mod 100;

   writeln(a1+a2);

 end

  else

    writeln('Число не является четырёхзначным');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота