В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ник4774
ник4774
24.12.2022 14:00 •  Информатика

НА ЛЮБОМ ЯЗЫКЕ (pascal abc, python? gnu c++, gnu c11, C# MS .Net 5.0) Ограничение времени 1 секунда
Ограничение памяти 64Mb
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt

У Васи есть n пустых коробок. Для каждого i (1 ≤ i ≤ n) i-я коробка — это куб со стороной длины ai.

Вася может положить коробку i в другую коробку j, если соблюдаются следующие условия:

i-я коробка не лежит в другой коробке;

j-я коробка не содержит других коробок;

коробка i меньше коробки j (ai < aj).

Вася может сколько угодно раз класть коробки друг в друга. Он хочет минимизировать количество видимых коробок. Коробка называется видимой, если она не лежит в какой-либо коробке.

определить минимальное возможное количество видимых коробок!

Формат ввода
В первой строке записано одно целое число n (1 ≤ n ≤ 5000) — количество коробок у Васи.

Формат вывода
Во второй строке записаны n целых чисел a1, a2, ..., an (1 ≤ ai ≤ 109), где ai — длина стороны i-й коробки.

Пример 1
Ввод Вывод
3
1 2 3
1
Пример 2
Ввод Вывод
4
4 2 4 3
2
Пример 3
Ввод Вывод
8
1 2 1 2 3 2 3 3
3

Показать ответ
Ответ:
AlinaNeizvestnaya20
AlinaNeizvestnaya20
04.04.2022 16:03

Вращение придает объекту стабильность в пространстве, этот принцип используют детский волчок, тарелочка-фрисби и пуля нарезного оружия. Любой из этих предметов можно назвать гироскопом, противодействующим отклонению от оси вращения.

Если вращающийся объект будет закреплен на оси с несколькими степенями свободы, то получится роторный гироскоп. Как только ротор будет раскручен, его ось приобретает устойчивость в пространстве и старается сохранить ориентацию, заданную в начальный момент.

Объяснение:

0,0(0 оценок)
Ответ:
Ильсяс
Ильсяс
22.01.2021 14:37

#include <iostream>

using namespace std;

задание 1

//int main()

//{

// int a[10], k;

// printf("enter numbers\n");

// for(int i = 0; i < 10; ++i)

// {

//  cin >> a[i];

//  if(a[i] % 2 == 0)

//  {

//   printf("%d\n", a[i]);

//   k++;

//  }

// }

// printf("k = %d", k);

//}

задание 2

//int main()

//{

// int a[10], k;

// printf("enter K\n");

// cin >> k;

// printf("enter numbers\n");

// for(int i = 0; i < 10; ++i)

// {

//  cin >> a[i];

//  if(a[i] < k)

//  {

//   printf("%d\n", a[i]);

//  }

// }

//}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота