В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mashadumbrava1
mashadumbrava1
08.06.2020 16:17 •  Информатика

Напишите программу: подсчитать количество нулей в массиве, состоящем из n целых чисел. элементы массива задавать вручную.

Показать ответ
Ответ:
Garri1209
Garri1209
11.08.2020 21:54

1. Динамический массив

program p_1;

var n,i,k:integer;

a:array of integer;

begin

write('Введите количество элементов массива ');

readln (n);

a := new integer[n+1];

for i:=1 to n do

begin

write('Введите ',i,' элемент массива ');

readln (a[i])

end;

k:=0;

for i:=1 to n do

if a[i] = 0 then k:=k+1;

writeln;

writeln('k = ',k)

end.

2. Статический массив

program p_1;

var n,i,k:integer;

a:array [1..1000] of integer;

begin

write('Введите количество элементов массива ');

readln (n);

for i:=1 to n do

begin

write('Введите ',i,' элемент массива ');

readln (a[i])

end;

k:=0;

for i:=1 to n do

if a[i] = 0 then k:=k+1;

writeln;

writeln('k = ',k)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота