В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vojnovv
vojnovv
01.05.2020 00:43 •  Информатика

На паскале дано одномерный массив действительных чисел: x = {0.01; -27.3; 0; 125.27; -371.45; 0; 12; -5; -172.3; 0.05; -17.1; 49.5; -0.01} и действительное число а = 5,34. составить программу обработки массива. вычислить произведение и количество элементов, которые не превышают числа √а.

Показать ответ
Ответ:
prestigpad
prestigpad
19.06.2022 07:53

Фрагменты таблиц истинности - в прилагаемом файле.

Так как в таблицах истинности выражений А и В нет совпадающих строк, то это значит, что значения в столбцах А и В противоположны. Т.е., там где для какого-либо набора переменных выражение А имеет значение 0, выражение В будет равно 1, и наоборот, если для какого-либо набора переменных выражение А имеет значение 1, выражение В будет равно 0. Следовательно, в столбце значений таблицы истинности выражения a v b все значения будут равны 1. Количество единиц = 2^6 = 64

ответ: 64

0,0(0 оценок)
Ответ:
tinapai
tinapai
27.03.2020 02:51
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота