В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
BatsonPlay
BatsonPlay
07.09.2021 18:40 •  Информатика

На питоне если хотя бы 1 решите будет очень очень круто, если можете еще решить буду благодарен. Если вам нужны то за 1 прогу дам 100 ( любую) очень Число 609 записали в системах счисления с основаниями от 2 до 10 включительно.
При каких основаниях крайние цифры в записи этого числа (самая левая и самая правая) имеют
разную четность? Например, число 124 – подходит, а 123 – нет, т.к. цифры 1 и 3 имеют
одинаковую четность (нечетные). В ответе укажите сумму всех подходящих оснований.
2)Число 364 записали в системах счисления с основаниями от 2 до 10 включительно. При каких
основаниях все цифры в записи этого числа одинаковые? В ответе укажите сумму всех
подходящих оснований.
3)Число 652 записали в системах счисления с основаниями от 2 до 10 включительно. При каких
основаниях в записи этого числа нет цифры 2? В ответе укажите сумму всех подходящих
оснований.

Показать ответ
Ответ:
Enjoy167
Enjoy167
05.11.2022 06:48

відповідь: function showresult(choise){

var n1=parsefloat(document.getelementbyid('num1').value);

var n2=parsefloat(document.getelementbyid('num2').value);

var r;

var c=choise;

switch(c)

{

case '1':

  r=n1+n2;

  break;

case '2':

  r=n1-n2;

  break;

case '3':

  r=n1*n2;

  break;

case '4':  

  r=n1/n2;

  break;

case '5':

  r=n2*100/n1;

  break;

default:

  break;

   

}

document.getelementbyid('result').value=r;

 

}

calculator

my calculator first number second number result

+

-

*

/

%

пояснення:

0,0(0 оценок)
Ответ:
sinocek1
sinocek1
03.07.2021 12:32

Описание алгоритма:

Будем наращивать длину последовательности от 0 знаков до N. Пусть после какого-то количества шагов у нас выписаны все последовательности длины А и мы хотим узнать количество подходящих последовательностей длины А+1. Распределим все последовательности на три группы(так как предыдущие символы нас не волнуют, то любые последовательности одной группы для нас равнозначны):

1) Заканчиваются на 0.

2) Ровно на одну единицу

3) Ровно на две единицы.

Из каждой последовательности группы 1 приписыванием нуля или единицы мы можем получить одну последовательность группы 1 и одну - группы 2. Неважно, какие именно, но они не перекрываются, т.к. предыдущие символы различны, хоть мы их и не учитываем. Точно так же из второй группы мы получаем одну последовательность группы 3 и одну группы 1, а из группы 3 - только группу 1. Таким образом, если количества последовательностей длины А по группам были (x, y, z), то для длины А+1 такое распределение будет (x+y+z, x, y). Если взять для длины 0 тройку (0, 0, 1) и просчитать тройки от 1 до N, получится искомое количество. Для a=1 и b=2 также работает правильно.

Программа на Pascal:

var num00,num01,num11,mem00:integer;

   a,i:byte;

begin

readln(b);

 num00:=1;

 for i:=1 to n do begin

   mem00:=num11;

   num11:=num01;

   num01:=num00;

   num00:=num01+num11+mem00;

 end;

writeln(num11+num01+num00);

end.

Объяснение:

извени если ошебусь

:)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота