На вход программы поступает последовательность из N целых положительных чисел. Нужно определить количество пар различных чисел, сумма которых делится на 12.
Описание входных и выходных данных
В первой строке входных данных задаётся количество чисел N (1 ≤ N ≤ 1000). В каждой из последующих N строк записано одно натуральное число, не превышающее 100.
Пример входных данных:
8
10
14
7
13
5
30
9
6
Пример выходных данных для приведённого выше примера входных данных:
3
В данном случае условиям удовлетворяют три пары: (10, 14), (7, 5) и (30, 6). Суммы чисел в этих парах (24, 12 и 36) делятся на 12.
#include <iostream>
using namespace std;
int main(){ cout << "Vvedute kol-vo ocenok" << endl;
int n,i,a,Four,Five; n = i = a = Four = Five = 0;
cin >> n;
for (i = 1; i <= n; i++) { cin >> a; if (a == 4){ Four++;} else if (a == 5) { Five++; } } if (Four > Five){ cout << "Four" << endl;} else if (Five > Four) { cout << "Five" << endl; } else { cout << "Equal"<< endl; } cout << "Kol-vo 4: " << Four << " Kol-vo 5: " << Five << endl; return 0;}