На языке python:
n школьников делят k яблок “почти поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1.
Программа получает на вход натуральное число n и целое неотрицательное число k, каждое в отдельной строке, и должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей.
Не должны использоваться If и циклы, только %; //; квадраты и все арифметические действия ( так же можно преоброазовывать даные если понадобится вам)
Автомобиль: двигатель, ходовая часть, трансмиссия, электрооборудование.
Школа: руководство, персонал, ученики, учителя, деление на классы.
Армия: главнокомандующие, различные виды войск, рядовые.
Государство: власть, политические партии, народ.
Компьютер: системный блок, оперативная память, центральный процессор, регистры.
2) Возьмем за пример
Водонагреватель. Служит для подогрева проходящей через него воды.
Входы: электропитание, холодная вода.
Выходы: горячая вода.
2. Телевизор. Устройство для демонстрации изображения со звуковым сопровождением.
Входы: электропитание, сигналы от внешних устройств, управление от пульта.
Выходы: звук изображение, сигналы на внешние устройства.
Объяснение:
begin
write('Введите первое число: ');
readln(a1);
write('Введите второе число: ');
readln(a2);
write('Введите третье число: ');
readln(a3);
if a1>0 then s:=s+1;
if a2>0 then s:=s+1;
if a3>0 then s:=s+1;
writeln(s);
end.
2) var n, s, i: integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
s:=s+i;
writeln(s);
end.
3) var n, s, i, k: integer;
begin
write('Введите число n: ');readln(n);
for i:=1 to n do begin
writeln('Введите рост ',i,' учащегося: ');
readln(k);
s:=s+k;
end;
writeln(s/i);
end.
4)var l, m: integer;
begin
write('Введите расстояние в сантиметрах: ');
readln(l);
m := l div 100;
write('Количество метров в ', l, ' сантиметрах = ', m);
end.