В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ритуа
ритуа
20.03.2020 17:04 •  Информатика

Надо написать программу которая по заданному числу n находит два числа- x и y разность квадратов которых равна n

Показать ответ
Ответ:
Winx1209
Winx1209
11.10.2020 01:06

Программа запускалась в PascalABC.NET

var x,y,n: integer;

begin

 writeln(' Введите n');

 readln(n);

 for x:=1 to 100 do

   for y:=1 to 100 do

     if sqr(x)-sqr(y)=n then

       begin

         writeln(x,' ',y);

         exit;

       end;

end.

Объяснение:


Надо написать программу которая по заданному числу n находит два числа- x и y разность квадратов кот
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота