В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Anyta15111
Anyta15111
21.04.2021 00:17 •  Информатика

Надо написать программу на dev c++ с библиотекой graphics.h чтобы появился телефон.

Показать ответ
Ответ:
marga23042002
marga23042002
24.08.2021 07:09
Составим табличку (фамилии обозначены одной буквой). Заполняем пошагово (советую себе в тетради нарисовать и самостоятельно заполнить, тогда поймёшь, как решается):

1) К - 2 ежа
2) К: кролик не 1, хомяк не 1, ежей 2 - значит 1 белка
3) И - 3 белки
4) И и П - 1 хомяк и 3 хомяка (или наоборот), значит у К могло бы быть 2 или 4 хомяка. Но у них 2 ежа, значит 4 хомяка, и значит 3 кролика
5) И и П - 1 хомяк и 3 хомяка (или наоборот). Поскольку у И 3 белки, значит у них 1 хомяк, а у П - 3 хомяка
6) И, П, К - кроликов не по 1, значит 1 кролик - у С
7) Сразу видно, что у С 2 хомяка
8) Сразу видно, что у С 3 ежа, и значит 4 белки
9) Сразу видно, что у П 2 белки
10) у П не может  быть 2 кролика (у них 2 белки), значит у П 4 кролика
11) у П 1 ёж
12) у И 4 ежа и 2 кролика

На логику любители животных. четыре семьи, дружившие между собой, держали по десять различных животн
На логику любители животных. четыре семьи, дружившие между собой, держали по десять различных животн
0,0(0 оценок)
Ответ:
slava02555
slava02555
15.08.2022 10:41
program corablik; uses Graph, Crt; var   grDriver: integer;   grMode: integer;   ErrCode: integer;   x,y,y0,a,b: integer;{a,b-переменные для линии моря, чтоб они не зависели от х,у}  procedure more(a,b:integer); begin moveto(0,y0); setcolor(blue); for a:=0 to 680 do{слева направо рисуем синусоиду синего чвета}   begin   b:=y0-round(sin(a*pi/180)*30);{30-коэффициент масштабирования по оси Х, чем больше, тем волна круче}   lineto(a,b);  end; end;  begin   grDriver := Detect;   InitGraph(grDriver, grMode, '..\BGI');   ErrCode := GraphResult;   y0 := 250;   if ErrCode = grOk then   begin     x:=600;     while x>=0 do{лучше использовать цикл while, можно менять величину шага, что тоже влияет на скорость и частоту смены картинки}      begin       cleardevice;       more(a,b);{рисуем волну}       setcolor(white);{устанавливаем цвет кораблика}       y:=y0-40-round(sin(x*pi/180)*30);{движемся по волне}       MoveTo(x - 40, y + 20);       LineTo(x - 20, y + 40);       LineTo(x + 20, y + 40);       LineTo(x + 40, y + 20);       LineTo(x - 40, y + 20);       MoveTo(x + 15, y + 20);       LineTo(x + 15, y - 40);       LineTo(x - 20, y + 20);       LineTo(x + 15, y + 20);       delay(100); {нормальная скорость, если модули *.TPL не глючные как у Вас,  время должно быть в миллисекундах, а не в каких-нибудь наносекундах}       x:=x-2;{шаг движения}     end;   end   else Writeln('Graphics error: ', GraphErrorMsg(ErrCode));  Settextstyle(0,0,3);{устанавливаем стиль шрифта}  cleardevice;  setcolor(red);  OuttextXY(200,240,'Rejs zavershen!');{выводим надпись}  readln;  CloseGraph; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота