В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Зариама08
Зариама08
11.01.2023 02:45 •  Информатика

Надо! составить программу для вычисления суммы ряда с точностью до ε = 10^-4. s = 1 + 3x + 5x^2 + 7x^3 + полученный результат сравнить с точным s = (1 + x)/(1-x)^2.

Показать ответ
Ответ:
12202020303030139
12202020303030139
08.10.2020 15:41
Begin
  var e: double;
  var s1: double;
  var s2: double;
  var x: double;
  var step: integer;
 
  readln(x);
 
  e := 0.0001;
  s1 := 1;
  step := 3;
 
  s2 := (1 + x) / (1 - x) / (1 - x);
 
  while abs(s1 - s2) > e do begin
    s1 := s1 + (1 + 2*step)/power(x, step);
  end;
 
  writeln(s1);
  writeln(s2);
  writeln(s1 - s2);
end.

Расставь правильно скобки в условии, я исправлю решение.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота