В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ангел809
ангел809
20.07.2020 07:18 •  Информатика

Надо составить программу, которая для любого натурального числа печатает количество цифр в записи этого числа. расписать все четко

Показать ответ
Ответ:
tomlinsondarya
tomlinsondarya
01.10.2020 17:36
Строками:
var s:string;
begin
WriteLn('vvedi chislo:');
ReadLn(s);
WriteLn('chislo cifr=',length(s));
ReadLn;
end;
Не строками:
var N,k:longint;
begin
write('N=');readln(N);
k:=0;
while N>0 do
begin
N:=N div 10;
k:=k+1;
end;
write('k=',k);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота