(надо составить программу либо на языке GNU C++ 5.4.0 либо на Pyton либо на Java JDK 1.8.0_171)
№1
Недавно Ваня и Даня играли в шахматы на перемене - и решили сделать из шахмат настоящую
головоломку. К счастью, это оказалось не так сложно, ведь у них в распоряжении оказалась не
просто доска 8 × 8, а доска n × m, а также n · m слонов.
Для начала (для будущего удобства) Ваня и Даня решили пронумеровать все клетки доски
змейкой, начиная с самой нижней клетки.
Как уже была сказано, у Вани и Дани в распоряжении есть очень много слонов, поэтому они и
будут «главными героями» их головоломки. Придуманная Ваней и Даней, головоломка заключается
в нахождение клетки с наибольшим значением magicchessp
, где magicchessp обозначает количество
итераций определенного алгоритма.
Сначала мы ставим слона в клетку с номером p, и пока у нас есть пустые клетки на поле, которые
бьются хоть одним слоном, мы будем выбирать из таких клеток минимальную по номеру – и ставить
туда слона. Количество итераций такого алгоритма и будет значением magicchessp
.
Теперь Даня и Ваня просят им с этой головоломкой, если известны n и m - размеры
доски. Но вам не требуется искать саму клетку с наибольшим magicchessp
, вам требуется найти
лишь максимальный magicchessp
.
№2
Сегодня на уроке зельеварения Ваня придумал для себя увлекательную игру. Сначала Ваня
ставит на числовой прямой три различных точки в целых координатах. После этого он может взять
одно из крайних чисел и переместить его в любую целую точку между двумя оставшимися, где
крайним мы называем минимальное или максимальное из чисел. Он повторяет это действие до тех
пор пока это возможно.
Например, если изначально выбрать точки {2, 4, 8}, после первого хода могут получится следующие комбинации чисел: {2, 3, 4}, {4, 5, 8}, {4, 6, 8}, {4, 7, 8}. В первом случае игра заканчивается
после первого же хода, в остальных случаях можно сделать еще хотя бы один ход.
Теперь Ване интересно, сколько ходов он может сделать для любой заданной тройки точек. К
сожалению Вани, зельеварение закончилось - и теперь он сам не успеет выяснить это ему!
Если (M = 1, 3, 5, 7, 8, 10, или 12) И (D <= 30), то (D = D + 1)
Если (M = 1, 3, 5, 7, 8, 10) И (D = 31), то (M = M + 1, D = 1)
Если (M = 12) И (D = 31), то (G = G + 1, M = 1, D = 1)
Если (M = 4, 6, 9, 11) И (D <= 29), то (D = D + 1)
Если (M = 4, 6, 9, 11) И (D = 30), то (M = M + 1, D = 1)
Если (M = 2) И (D <= 27), то (D = D + 1)
Если (M = 2) И (G mod 4 <> 0) И (D = 28), то (M = 3, D = 1)
Если (M = 2) И (G mod 4 = 0) И (D = 28), то (D = D + 1)
Если (M = 2) И (G mod 4 = 0) И (D = 29), то (M = 3, D = 1)
Если (M = 2) И (G = 1900 или 2100) И (D = 28), то (M = 3, D = 1)
В последней строчке я учёл разницу между Григорианским и Юлианским календарями.
По Юлианскому после 28.02 1900 или 2100 года наступит 29.02.
По Григорианскому наступит 01.03.
begin
var arr := ArrRandomReal(ReadInteger('N ='), 0, 1);
writeln('[0; 0.25): ',
arr.Where(x->(x>=0) and (x<0.25)).Count);
writeln('[0.25; 0.5): ',
arr.Where(x->(x>=0.25) and (x<0.5)).Count);
writeln('[0.5; 0.75): ',
arr.Where(x->(x>=0.5) and (x<0.75)).Count);
writeln('[0.75; 1): ',
arr.Where(x->(x>=0.75) and (x<1)).Count);
end.
Можете её запускать при разных N. У меня получилось так (четыре числа - число попавших в интервал):
N = 10.
3, 1, 2, 4
N = 100.
21, 29, 21, 29
N = 1000.
272, 240, 241, 247
N = 10000.
2588, 2383, 2464, 2565
Результаты могут отличаться (массив из случайных чисел генерируется, всё-таки), но тенденция должна быть такой: в каждый интервал должны попадать примерно четверть всех точек, притом с увеличением N отклонение доли попавших в тот или иной полуинтервал должно отклоняться от 25% всё меньше.