В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
арсен157
арсен157
28.01.2021 13:38 •  Информатика

Написать код на C

Составьте программу, которая бы выполняла следующие действия:

1) принять с клавиатуры два целых числа (d1 - деленное и d2 - делитель)

2) проверить их на корректность: если d2 == 0, либо одновременно d1 == d2 == 0 - вывести соответствующие сообщение и повторить ввод (вернуться на п.1)

3) рассчитать долю и остаток от их деления;

4) в зависимости от того, чему равен остаток - вывести на экран d2 раз долю и в конце - остаток (один раз) с различных циклов:

- если остаток == 1 - цикла с известным количеством повторений (for)

- если остаток == 2 - цикла с условием (while)

- если остаток == 3 - цикла с постусловием (do-while)

- в противном случае - по повторно ввести деленное и делитель (переход на п.1)

Показать ответ
Ответ:
kilaur
kilaur
18.07.2021 10:20
Блок-схема - в прилагаемом файле.
Программа:
#include <iostream>
#include <stdlib.h>
using namespace std;

int main() {
const int n = 20;
int a[n];
int k1=0;
int k2=0;
int k3=0;

srand(time(0));
for (int i = 0; i < n; i++) {
a[i]=rand() % 3 +1;
cout << a[i] << " ";
}
cout <<"\n";
for (int i = 0; i < n; i++){
 switch(a[i]){
case 1: 
k1++; break;
case 2: 
k2++; break;
case 3: 
k3++; break;
 }
}
   cout << "k1 = " << k1 << "  k2 =  " << k2 << "  k3 =  " << k3 <<"\n"; 
return 0;
}

Пример:
2 1 2 1 2 1 3 3 2 3 1 3 1 2 3 2 1 3 3 3
k1 = 6 k2 = 6 k3 = 8
0,0(0 оценок)
Ответ:
rozik080
rozik080
24.05.2022 07:01
Насекомые обладают сегментированными телами, поддерживающимися экзоскелетом - твердым внешним покрытием, состоящим главным образом из хитина. Сегменты тела объединены в три области: голова, грудная клетка, и живот. На голове находится пара сенсорных антенн, пара сложных глаз, один - три простых глаза и три набора по-разному измененных придатков, которые формируют ротовой аппарат. На грудной клетке находится шесть ног (по одной паре на сегмент) и два или четыре крыла (если таковые характерны для разновидности) . Живот (составленный из одиннадцати сегментов, некоторые из которых могут быть уменьшены или сросшиеся) заключает в себе большинство пищеварительных, дыхательных, выделительных и репродуктивных внутренних органов.
Вот так сойдет 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота