В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Afyz1
Afyz1
30.07.2021 00:04 •  Информатика

Написать код на с++, python или pascal♥

некоторое натуральное количество шишек мишка разложил на две кучки с числом шишек в каждой a и b и предложил маше сыграть с ним в следующую игру: за один ход разрешается взять произвольное натуральное количество шишек, но только из одной кучки. выигрывает тот, кто забрал последнюю шишку. маша всегда ходит первой.

определите для заданных a и bкто выигрывает при оптимальной игре каждого из игроков.

входные данные

в первой строке задано количество тестовых случаев n (1 ≤ n≤ 105). в последующих n строках заданы по два неотрицательных целых числа a и b, каждое из которых не превышает 2·109.

выходные данные

в единственной строке выведите без пробелов последовательность из n цифр 1 или 2 - номер игрока, выигрывающего при оптимальной игре в очередном тестовом случае.

входные данные
3
3 5
1 1
4 1
выходные данные
121

Показать ответ
Ответ:
Suslik1111
Suslik1111
03.10.2020 13:34

Объяснение:

Синтаксис могу плохо помнить:

#include <iostream>

using namespace std;

int main(void){

int x,y,i,N;

cin>>N;

for(i=0;i<N;i++){

cin>>x>>y;

if(x==y) cout<<"2";

else cout<<"1";

}

return 0;

}

Выигрышная стратегия-постоянно уравнивать большее число к меньшему, так игра в конечном итоге сведётся для оппонента к проигрышной позиции (1,1) при оптимальной игре каждого игрока. Так, получается что позиции с равными числами заведомо проигрышные, а с разными-выигрышные для игрока, делающего ход.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота