В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
jojo31
jojo31
12.02.2022 19:12 •  Информатика

написать коды для этих задач на с++, очень нужно( 1) Напишите программу, которая находит сумму двух заданных чисел и выводит результат вввиде примера A + B = SUM. Программа должна считываться из файла input.txt и выводиться output.txt 2)Улитка ползет по вертикальному шесту высотой h метров, поднимаясь за день на a метров, а за ночь спускаясь на b метров. На какой день улитка доползет до вершины шеста? Во входном файле input.txt записано три числа. в выходном файле output.txt ответ. (числа: 10, 3, 2, ответ: 8) 3)Напишите программу, вычисляет сумму цифр трехзначного целого числа Во входном файле input.txt записано целое число N. В выходном файле output.txt необходимо вывести одно число - сумму цифр числа N. 4)n школьников делят k яблок поровну, неделяющийся остаток остается в корзинке. Сколько яблок достанется каждому школьнику? Во входном файле input.txt записано два натуральных числа K и N. Оба числа меньше 10000. в выходном файле output.txt выведите одно число - ответ на вопрос в условии задачи. 5)напишите программу которая переставляет элементы массива в обратном порядке без использовании дополнительного массива. Программа должна считать массив, поменять порядок его элементов, затем вывести результат (просто вывести элементы массива в обратном порядке - недостаточно!). (input.txt\output.txt)

Показать ответ
Ответ:
Петрович05
Петрович05
10.09.2020 20:39

n = int(input())

for i in range(0, n):

   k = int(input())

m = 0

n = int(input())

for i in range(0, n):

   k = int(input())

m = 0

n = int(input())

for i in range(0, n):

   k = int(input())

   if (k % 5 == 0) and (k > m):

       m = k

m = 0

n = int(input())

for i in range(0, n):

   k = int(input())

   if (k % 5 == 0) and (k > m):

       m = k

print(m)

Объяснение:

Объявим переменную m, где мы будем хранить ответ, равную 0 (так как в задании представлены натуральные числа, а 0 является ближайшим ненатуральным), и запишем ее в начало программы.Теперь можем работать с переменной k. Если остаток от деления на 5 равен 0 (т.е. кратно 5) и значение k больше значения m (т.к. m — наш ответ), то присвоим значение из переменной k переменной m.И в самом конце выводим переменную m — наш ответ.

0,0(0 оценок)
Ответ:
arinabolshakov1
arinabolshakov1
16.03.2021 04:09

Задание 1

#include <iostream>

using namespace std;

int main() {

int a, b;

cin >> a >> b;

cout << a - b;

}

Задание 2

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a;

cin >> a;

cout << pow(a, 2) << ' ' << pow(a, 3)<< ' ' << pow(a, 5);

}

Задание 3

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a;

cin >> a;

cout << "The next number for the number " << a << " is " << a + 1 <<"!\n" <<"The previous number for the number "<< a << " is " << a - 1 <<"!";

}

Задание 4

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a;

cin >> a;

cout << (3 * pow(a, 3) + 18 * pow(a, 2)) * a + 12 * pow(a, 2) - 5;

}

Задание 5

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a, b, c;

cin >> a >> b >> c;

cout << a % 7 << "\n" << b % 7 << "\n" << c % 7;

}

Задание 6

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a, b, c, a1, b1, c1;

cin >> a >> a1 >> b >> b1 >> c >> c1;

cout << a1 % (8 - a) << "\n" << b1 % (8 - b) << "\n" << c1 % (8 - c);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота