Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
raha12003
18.02.2022 22:09 •
Информатика
написать одну из частей программы! Язык Python! Нужно преобзовать массив таким образом, чтобы в первой его половине располагались элементы, стоявшие в четных позициях, а во второй половине - элементы, стоявшие в нечетных позициях.
Показать ответ
Ответ:
sosochek47
10.05.2020 15:58
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
procedure SUM(x,y,z:array of integer);
begin
for var i:=0 to z.Length-1 do z[i]:=x[i]+y[i]
end;
procedure ArrPrint(x:array of integer);
// никому она не нужна, на раз попросили...
begin
x.Println(', ');
end;
procedure ArrInit(var x:array of integer;n,from,&to:integer);
// никому она не нужна, на раз попросили...
begin
x:=ArrRandom(n,from,&to)
end;
begin
var a,b,c:array of integer;
ArrInit(a,15,10,30); ArrPrint(a);
ArrInit(b,15,25,60); ArrPrint(b);
SetLength(c,15);
SUM(a,b,c); ArrPrint(c)
end.
Тестовое решение:
23, 15, 13, 23, 22, 24, 20, 27, 29, 19, 29, 28, 30, 10, 24
48, 32, 31, 59, 36, 34, 47, 28, 42, 30, 40, 58, 25, 30, 33
71, 47, 44, 82, 58, 58, 67, 55, 71, 49, 69, 86, 55, 40, 57
0,0
(0 оценок)
Ответ:
Синтол
22.10.2022 00:07
#include <iostream>#include <stdlib.h>#include <locale.h>using namespace std;
void main(){ setlocale(0, ""); int a = 100, num, player = 1, correct; while (a > 0) { if (player == 1) { do { cout << "Ваш ход. На столе " << a <<" спичек" << endl; cout << "Сколько спичек вы берете?" << endl; cin >> num; if ((num > 0) && (num <= 10)) { correct = true; } } while (correct != true); } else { if ((a <= 10) && (a > 1)) { num = a - 1; } else if (a == 1) { num = 1; } else { if (num > a) { num = a; } } cout << "Компьютер взял " << num << " спичек" << endl; } a = a - num; if (player == 1) { player = 2; } else { player = 1; } } if (player == 1) { cout << "Вы проиграли" << endl; } else cout << "Вы победили" << endl; system("pause");}
0,0
(0 оценок)
Популярные вопросы: Информатика
mur181
06.11.2022 08:12
Сканируется цветное изображение размером 20 х 20 . разрешающая сканера 300 dpi и глубина цвета 24 бита. какой информационный объем будет иметь полученный графический...
vadimmka666
29.04.2022 17:01
Дано n, массив а из n вещественных элементов и число k, k 0. подсчитать в нем среднее значение для тех положительных элементов массива,величина которых меньше k....
Данил3472
27.12.2020 14:45
Информатика рассчитайте объём видео памяти,необходимой для хранения изображения,занимающего весь экран монитора с разрешением 256*352 и количеством отображаемых...
yoongi2017
24.11.2021 09:09
Ниже записан алгоритм. укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 2. var x, a, b, c: longint; begin readln(x); a:...
nikoszahar
17.03.2022 02:45
работа в excel! задано целое число, лежащая в промежутке от 0 до 99. программа должна вычислить сумму цифр этого числа. для выделения первой и последней цифры воспользуйтесь...
Азяка21
18.03.2023 01:53
Нужно написать программу на с++ мы вводим массив из букв, а программа должна их отсортировать по алфавиту...
vita142
01.04.2023 04:25
Выберите неверные утверждения программа - это универсальный алгоритм для любого исполнителя исполнитель всегда одинаково выполняет команды исполнитель может выполнять...
VasyaHrenov
13.08.2020 23:06
Определили значение переменной....
enbasmanovan
09.07.2021 04:19
Объясните и напишите код программы на языке с++1. напишите программу, которая сравнивает количество перестановок при сортировке одного и того же массива разными...
XeaTeaK
04.03.2023 18:53
Просто подробно и пошагово объясните мне, тупому пеньку, что делать? ^^ ! а то я совсем не разбираюсь в lazarus, хоть это самая примитивная среда. ....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
procedure SUM(x,y,z:array of integer);
begin
for var i:=0 to z.Length-1 do z[i]:=x[i]+y[i]
end;
procedure ArrPrint(x:array of integer);
// никому она не нужна, на раз попросили...
begin
x.Println(', ');
end;
procedure ArrInit(var x:array of integer;n,from,&to:integer);
// никому она не нужна, на раз попросили...
begin
x:=ArrRandom(n,from,&to)
end;
begin
var a,b,c:array of integer;
ArrInit(a,15,10,30); ArrPrint(a);
ArrInit(b,15,25,60); ArrPrint(b);
SetLength(c,15);
SUM(a,b,c); ArrPrint(c)
end.
Тестовое решение:
23, 15, 13, 23, 22, 24, 20, 27, 29, 19, 29, 28, 30, 10, 24
48, 32, 31, 59, 36, 34, 47, 28, 42, 30, 40, 58, 25, 30, 33
71, 47, 44, 82, 58, 58, 67, 55, 71, 49, 69, 86, 55, 40, 57
void main(){ setlocale(0, ""); int a = 100, num, player = 1, correct; while (a > 0) { if (player == 1) { do { cout << "Ваш ход. На столе " << a <<" спичек" << endl; cout << "Сколько спичек вы берете?" << endl; cin >> num; if ((num > 0) && (num <= 10)) { correct = true; } } while (correct != true); } else { if ((a <= 10) && (a > 1)) { num = a - 1; } else if (a == 1) { num = 1; } else { if (num > a) { num = a; } } cout << "Компьютер взял " << num << " спичек" << endl; } a = a - num; if (player == 1) { player = 2; } else { player = 1; } } if (player == 1) { cout << "Вы проиграли" << endl; } else cout << "Вы победили" << endl; system("pause");}