В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу c++ для решения следующей : упорядочить по возрастанию элементы каждой строки матрицы а(10,8) и вывести ее в виде таблицы.

Показать ответ
Ответ:
sashkaaaxo
sashkaaaxo
05.08.2020 10:19

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

   int m=10, n=8;

   int a[m][n];

   srand(time(0));

   for(int i=0; i<m; i++)

   {

       for(int j=0; j<n; j++)

       {

           a[i][j]=-99+rand()%199;

           cout << setw(4) << a[i][j];

       }

       cout << endl;

   }

   cout << endl;

   // сортировка

   int t;

   for(int i=0; i<m; i++)

   {

       for(int k=n-2; i>=0; i--)

           for(int j=0; j<=k; j++)

               if(a[i][j] > a[i][j+1])

               {

                   t=a[i][j]; a[i][j]=a[i][j+1]; a[i][j+1]=t;

               }

       for(int j=0; j<n; j++)

           cout << setw(4) << a[i][j];

       cout << endl;    

   }

   return 0;

}

Прилагается пример вывода.


Написать программу c++ для решения следующей : упорядочить по возрастанию элементы каждой строки мат
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота