Написать программу если в массиве (из n чисел) есть хотя бы одна тройка соседних чисел, в которой средний элемент больше своих "соседей", т. е. предшествующего и последующего, то напечатать все элементы, предшествующие элементам последней из таких троек.
var i,n,itre:integer;
a:mas;
begin
readln(n);
for i:=1 to n
do read(A[i]);
for i:=2 to n-1
do if (A[i]>A[i-1]) and (A[i]>A[i+1])
then itre:=i;
for i:=1 to itre-2
do writeln(A[i]);
end.